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Easy Favorites
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Distinguish Record Types by Color
-Visually distinguishes Authority records from Bibliographic records 
-Toolbar Tab: Tools > Options… > Record Display tab > 

Colors Element: [choose option] > Define… > [choose basic or custom color] > OK
-Example: Authority Text

Partial view of Emily’s Connexion Client screen. Authority record on left in blue and bib record on right in default white.



Easy Favorites, continued

WorldCat Quick Search box
-default option

Source: OCLC Connexion: Searching WorldCat Quick Reference, page 4

Source: OCLC Connexion: Searching WorldCat Quick Reference, page 3
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OCLC Connexion Search Resources: 
- Bibliographic searching, Connexion client training website Modules 2 and 7
- OCLC Connexion: Searching WorldCat Quick Reference

Partial view of Emily’s Connexion Client Toolbar

https://help.oclc.org/Metadata_Services/Connexion/Connexion_client_training
https://www.oclc.org/content/dam/support/worldcat/documentation/searching/refcard/searchworldcatquickreference.pdf


Easy Favorites, continued
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Partial view of Emily’s Connexion Client Toolbar

Pinned [Pin]
-Toolbar Tab: View > Pinned
-Shift+F4
-Display above is a toolbar customization

Tile Vertically
-Toolbar Tab: Window > Tile Vertically
-Side by side on a horizontal plain
-Alternative: Tile Horizontally
-Display above is a toolbar customization

Control All Headings
-Toolbar Tab: Edit > Control Headings > All
-Shift+F11
-Display above is a toolbar customization



Toolbar Customization
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-Add a button:
Toolbar tab: Tools > Toolbar Editor… > Record Display tab > [select Menu Item*] > click and drag Menu Item and drop on 
Toolbar

*Note: Menu Items are named according to the toolbar navigation trail for a specific command
They are organized alphabetically

Examples: Toolbar tab + Comand
ViewPinned
View = toolbar tab Pinned = Command

Toolbar tab + Command + Subcommand
EditControlHeadingsAll
Edit = toolbar tab ControlHeadings = Command All = Subcommand

-Remove a button:
Toolbar tab: Tools > Toolbar Editor… > Hold down the Alt key on your keyboard while you click and drag the offending 
button from toolbar to the list of Menu Items and unclick, or drop within the box

-Relocate a button:
Hold down the Alt key on your keyboard while you click a toolbar button, then drag and drop it to a new location.

Purpose: Places a button/icon on your toolbar that links to your most heavily 
used menu commands and/or User Tools. In doing so, you avoid the cumbersome 
file navigation for frequently used commands.

-Some buttons are part of the default toolbar display and are removable
-Buttons, including those on display by default, can be reordered/reorganized



Toolbar customization, continued
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To add a button to your toolbar, click and drag selected 
Menu Item to where you’d like it on the toolbar.

To remove a button from your toolbar (including default 
buttons), hold down the Alt key on your keyboard while 
you click and drag the button from toolbar to the list of 
Menu Items.

To rearrange buttons on your toolbar (including default 
buttons), hold down the Alt key while clicking and 
dragging the button to its new location.

Original arrangement

Rearranged buttons

OCLC Connexion Search Resources: 
- Add, remove, or change the position of buttons on the Connexion client toolbar, OCLC Connexion Troubleshooting (2018)

https://help.oclc.org/Metadata_Services/Connexion/Troubleshooting/Add_remove_or_change_the_position_of_buttons_on_the_Connexion_client_toolbar


Constant Data
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Definition: A saved record template of set indicators, fields, etc. to be used when 
cataloging an item with those attributes. Once created, it can be shared with all 
users from your library.

Examples: Finding Aid template for use by non-cataloging staff
Apply ‘closed caption’ related fields to video records

Purpose: Provide efficiency and consistency to your records

Features: User-created
Create from a blank workform, an existing bib record, or existing constant data
Use on fixed fields, variable fields or both
Save to local or online files
Applied to single or multiple record(s)

OCLC Constant Data Resources: 
-Cataloging: Use Bibliographic Constant Data, OCLC Connexion Client Guides (2016)
-Authorities: Use Authority Constant Data, OCLC Connexion Client Guides (2006)
- Automation and customization, Connexion client training website, Module 5
-OCLC Connexion Client Cataloging Quick Reference, pages 4, 7, 8, 10, 11
-Tran, M. (2014). Create Constant Data in Connexion Client. Connexion Client Training Videos Series. Video retrieved from 
https://www.youtube.com/watch?v=dyvGVUqHbqw
-Tran, M. (2014). Apply Constant Data in Connexion Client. Connexion Client Training Video Series. Video retrieved from 

https://www.youtube.com/watch?v=VrT2sWOyV6k

https://www.youtube.com/watch?v=VrT2sWOyV6k
https://help.oclc.org/@api/deki/files/5173/connexion-client-use-bib-constant-data.pdf?revision=2
https://help.oclc.org/@api/deki/files/5152/connexion-client-use-authority-cd.pdf?revision=2
https://help.oclc.org/Metadata_Services/Connexion/Connexion_client_training
https://www.oclc.org/content/dam/support/connexion/documentation/client/cataloging/catquickref/connexionclientquickref.pdf
https://www.youtube.com/watch?v=dyvGVUqHbqw
https://www.youtube.com/watch?v=VrT2sWOyV6k


Constant Data, continued
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Create New:

Toolbar tab: Cataloging > Create > 
Constant Data…

Select Workform Type from list of 
options > OK



Constant Data, continued
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Bibliographic Constant Data Workform opens

*Note: 
-The workform type selected on previous prompt provides basic 
coding for the record
-Both fixed and variable fields can be edited
-Use * in a fixed field if you want the data in the edited bib record to 
be used

Example: Lang / Ctry / DtSt / Dates

Once edits made, click Reformat (Edit > Reformat or R 
toolbar button) to remove all empty/extraneous fields.



Constant Data, continued
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Once workform is complete, save the file

Toolbar tab: Action > Save Record to Online File
OR

Toolbar tab: Action > Save Record to Local File

Create Constant Data Name > OK

*Note
-Name it something meaningful to you and others (if sharing)
-Consider including Workform type and whether it includes fixed, 
variable, or both field types. This will be helpful when you apply 
constant data to a record in six months and your memory isn’t so 
good on what’s included in the workform.



Constant Data, continued
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Search for Constant Data:

Toolbar tab: Cataloging > Search > 
Online Constant Data… or Local Constant Data…

Double-click an existing constant data workform to 
open and edit.

Save an edited workform:

Toolbar Tab: Action > Save Record to 
Online File or Save Record to Local File
File is saved.

Delete an existing workform:

Select workform from list > Toolbar tab: Action > Delete Record



Constant Data, continued
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To apply to a record:

Open bib record

Toolbar tab: Edit > Constant Data > 
Choose Online or Local > Apply from List

Search Online Bibliographic Constant Data 
pop-up box appears > OK



Constant Data, continued
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Online Bibliographic Constant Data 
List in: “[OCLC Symbol]” opens

Select the name of the constant data 
you want to apply

Select the Choose Fields to Apply:
Fixed
Variable
Both

> Apply Selected

The changes specified in the 
Constant Data workform will be 
made to your bib record

*Note:
This is the point in the process at which the 
naming convention becomes important.



Text Strings
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Definition: Strings of text (phrases, fields w/phrases, etc.) you commonly add to a 
MARC record you are editing/creating.

Examples:
264  _4 $c ©20xx
504  _ _ $a Includes bibliographical references (xx-xx) and index.
Relator terms:   , $e author.
590  _ _ $a Labor Collection. (GSU Atlanta Campus)
655  _7 $a Videorecordings for the hearing impaired. $2 lcgft

Purpose: Prevent typing errors, ensure consistent phrasing and save time.

Features: User-created
Stored locally
Shared (ability to import/export)

OCLC Text String Resources: 
- Basics: Set Options and Customize, OCLC Connexion Client Guides. (2016), pages 47-52
- OCLC Connexion Client Cataloging WorldCat Quick Reference, page 4
- Tran, M. (2014). Create and use text strings in Connexion client. Connexion Client Training Videos Series. Video retrieved 

from https://www.youtube.com/watch?v=Z6-Tw_G6kic
- Automation and customization, Connexion client training website, Module 5

https://help.oclc.org/@api/deki/files/5159/connexion-client-set-options-and-customize.pdf?revision=2
https://www.oclc.org/content/dam/support/connexion/documentation/client/cataloging/catquickref/connexionclientquickref.pdf
https://www.youtube.com/watch?v=Z6-Tw_G6kic
https://help.oclc.org/Metadata_Services/Connexion/Connexion_client_training


Text Strings, continued
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Where:

Toolbar tab: Tools > Text Strings…

Text Strings Quick Tool on Toolbar

Text Strings Quick Tool dropdown 
arrow > Manage



Text Strings, continued
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Creating a text string:
-Pop-up box will show all text strings.

If you’ve not created any, this box will be empty.
-To create a new one, click Add.



Text Strings, continued
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Text:
Enter the text exactly as you want it 
to appear in a record.

Example: 
,[space][ctrl+d]e[space]editor.

Description Field:
Name it something meaningful that 
indicates what it will do for you

Example: Editor relator

*Note: In this example, don’t hit the return or enter key at the end of the text, just press ok. Return or enter 
is the command for creating a new field, and not an intended action for this text string.

-For this particular text string, once selected, it will be placed where your cursor is. You’ll need to be mindful 
of this and remember to remove any unnecessary punctuation once the text string has been placed.



Text Strings, continued
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Description Field:

Example: 264 copyright date

Text:
Place your cursor in the text 
box; hit the enter key on your 
keyboard to create a new field.
type the field number you 
want to add

*Note: By adding “20xx”, the field will have to be edited once added to the record. Using the xx, creates a 
visual cue for an edit that you are more likely to see before publishing/updating the record.

Example:  264[space]4[ctrl+d]c[click Enter Diacritics… and select copyright symbol]20xx



Text Strings, cont’d
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Place the cursor anywhere 
within the field above where the 
new field should be added.

Select the text string 
from the list of options.

The new field will be created 
and the phrasing added.



Text Strings, continued
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*Note:
-Be mindful of your cursor placement within the record before applying a text string
-A text string can be comprised of a limitless number of characters
-Text strings are stored in a single file named TextStrings.xml on your hard drive

X:\Documents and Settings\[user name]\ApplicationData\OCLC\Connex\Profiles\MyProfile, 
where X is the letter of your hard drive

-Assigned text strings are retained each time you open or update your program

From the Text Strings editor box:

-Modify/delete existing text strings
-Import a file of text strings
-Re-order/sort your text strings
-Print a list of text strings
-Create shortcuts to your text strings by assigning them to User 

Tools and Keystroke commands



Macros
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Definition: A single instruction that expands automatically into a set of instructions 
to perform a particular task; short computer programs that automate routine tasks

Examples:
RDA records: add 33x fields
Change the case of your selected text

ALL CAPS to Sentence case or lowercase or Initial Capital Letters
Browse the Authority Index based on a heading in your authority or bib record
Add/Edit an 007 through a prompted menu
Add or remove punctuation based on PCC policy
Update holdings and export bib record

Purpose: Provide efficiency and consistency to more complicated tasks.

Features: Pre-loaded or User-created
Updated/Shared:   X:\Program Files (x86)\OCLC\Connexion\Program\Macros 

as OCLC.mbk, Dewey.mbk, etc. (X = drive letter for your computer)

OCLC Macros Resources: 
- Basics: Set Options and Customize, OCLC Connexion Client Guides. (2016), pages 19, 54
- Basics: Use Macros, OCLC Connexion Client Guides (2016)
- Connexion client macros, OCLC Support (2020)
- Automation and customization, Connexion client training website, Module 5

https://www.youtube.com/watch?v=VrT2sWOyV6k
https://help.oclc.org/@api/deki/files/5159/connexion-client-set-options-and-customize.pdf?revision=2
https://help.oclc.org/@api/deki/files/5158/connexion-client-macros.pdf?revision=2
https://help.oclc.org/Metadata_Services/Connexion/Connexion_client/Connexion_client_macros
https://help.oclc.org/Metadata_Services/Connexion/Connexion_client_training


Macros, continued
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Where:

Toolbar tab:
Tools > Macros > side menu > Manage…

Pop-up box appears

The Macro manager is pre-
loaded with books of macros: 
Dewey and OCLC.

From this box:
- Create new books
- Create new macros
- Edit macros
- Delete macros



Macros, continued
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Running or Applying:

Open a record > Toolbar tab: Tools > 
Macros > side menu > Manage… >
From pop-up, double-click a book name > 
Select a macro > Run

The changes will be made to your record.

*Note: This OCLC Add33x macro creates a pop-up 
box with drop-down menus for you to select the 
appropriate attributes. Not all macros run this way.



Macros, continued
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Editing:

Toolbar tab: Tools > Macros > side menu > 
Manage… > From pop-up, double-click a book 
name > Select a macro > Edit… >
OCLC Connexion Macro Editor and Debugger 
box opens, displaying the macro’s code



Macros, continued
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How to create:

-From scratch within OCLC using a macro editor

Joel Hahn, Niles Public Library District, Illinois, has written how-to guide 
which includes how to import macros created by your colleagues.

http://www.hahnlibrary.net/libraries/oml/index.html

-Using a macro recorder to capture your actions and the client writes it for you

Merry Morris, Free Library of Philadelphia, has written a guide that covers 
how to use the macro recorder.

http://computerwhizzard.50megs.com/

Where to find OCLC macros:
- Connexion client macros, OCLC Support (2020) provides information about pre-

loaded and additional resources including the following:
- Joel Hahn’s website: http://www.hahnlibrary.net/libraries/oml/index.html
- Walt Nickeson’s macros: https://github.com/wnickeson/WaltsMacros

*Note:
-Do not create new macros in the OCLC or Dewey macro books. If/when upgraded, locally created macros 
in this folder/book will be overridden.

http://www.hahnlibrary.net/libraries/oml/index.html
http://computerwhizzard.50megs.com/
https://help.oclc.org/Metadata_Services/Connexion/Connexion_client/Connexion_client_macros
http://www.hahnlibrary.net/libraries/oml/index.html
https://github.com/wnickeson/WaltsMacros


User Tools
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Definition: Shortcut to a command

Examples:
Enter a diacritic or special character (©, &, etc.)
Run a macro (add 3xx fields)
Issue a menu command (Delete record)
Insert a text string (504 field)

Purpose: Provides a way to group your 10 most frequently used commands into 
one area.

Features: User-assigned

OCLC User Tool Resources: 
- Basics: Set Options and Customize, OCLC Connexion Client Guides. (2016), pages 43-46
- Automation and customization, Connexion client training website, Module 5

https://www.youtube.com/watch?v=VrT2sWOyV6k
https://help.oclc.org/@api/deki/files/5159/connexion-client-set-options-and-customize.pdf?revision=2
https://help.oclc.org/Metadata_Services/Connexion/Connexion_client_training


User Tools, continued
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Where:

Toolbar tab: Tools > User Tools

User Tools Quick Tool on Toolbar



User Tools, continued
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How to Assign:

Toolbar Tab: Tools > 
User Tools > Assign…

User Tools Quick Tool > Manage…



User Tools, continued
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User Tools editor box opens.

Category options: Character, Macro, 
Menu Item, Text (Text String)

Select a category. Example: Character

List of Characters displays in window. 

Select a frequently used character.
Example: Copyright mark

Select New User Tool: drop down menu 

Select the User Tool number for your 
chosen comand (only 1-10)

Example: Tool 3

Click Assign Tool.



User Tools, continued
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Modify the User Tool 
description to make it more 
meaningful to you

Modify Description… > 
[change Description Text: > OK

This newly assigned User Tool is now 
available in your list of User Tools.



User Tools, continued
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How to Unassign:

Repeat the same steps used 
when assigning a command.

Once the command is 
highlighted in the window, the 
User Tool assignment will be 
visible in the Current User 
Tools: window.

Select that assignment.

Click Unassign Tool

*Note:
- Only 10 slots for assignment available; listed as a number, 1-10, from the User Tool menu
- When assigning User Tools, always click Assign Tool in the pop-out box to apply the changes.
- Careful! More than one command can be assigned to a User Tool. Unassign the existing 
command before assigning a new command.



Backup Customizations
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Customizations are stored in data files which are then stored in folder: \MyProfile

File location on computer:
X:\Users\[user name]\AppData\Roaming\OCLC\Connex\Profiles\MyProfile\
*X should be replaced with the letter corresponding to your hard drive

Table from Getting Started with OCLC Connexion Client, OCLC Connexion Client Guides (2019) Page 33

OCLC User Tool Resources: 
- Getting Started with OCLC Connexion Client, OCLC Connexion Client Guides (2019) pages 33-37
- How do I copy Connexion client files from one PC to another? OCLC Connexion Troubleshooting (2019)

https://www.youtube.com/watch?v=VrT2sWOyV6k
https://help.oclc.org/@api/deki/files/5141/connexion-client-getting-started.pdf?revision=3
https://help.oclc.org/Metadata_Services/Connexion/Troubleshooting/How_do_I_copy_Connexion_client_files_from_one_PC_to_another


Backup Customizations, continued
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Quick access to Connexion Client Files: 

Toolbar Tab: View > User Information > Paths and Logs… > pop-up box appears with 
your Current Profile Path:



Backup Customizations, continued
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*Note:
-Backing up your profile will be helpful:

-Setting up new authorization profiles for new cataloging staff
-If obtain new computer and Connexion Client is newly installed
-There’s a global pandemic, and you need to install Connexion Client on a home 
computer or laptop

-If you don’t have Administrative rights to your computer, you’ll need to work with 
the person who does.

-The address is likely to be different for each computer and user, so use caution as it’s 
not as easy as replacing one folder with another.

-Read the documentation! Ask for help!
-Don’t attempt unless you’re really confident you can fix anything you’ve broken!
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Thank you!
Emily: ewilliams63@gsu.edu

Nothing will work unless you do.
-Maya Angelou


